Started 9 days agoJuly 24, 2026Lasted about 2 hoursJuly 24, 20265:307:42 PMUTC
Affected
Lead Portal
Degraded performance from 5:30 PM to 7:42 PM
HELOC
Degraded performance from 5:30 PM to 7:42 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
We have identified an outage with our email service, causing delays in email delivery, including emails containing one-time passcodes. It is currently fixed, but will take some time for backlogged emails to process.